| 1 |
|
2008-03-05 Wakaba <[email protected]> |
| 2 |
|
|
| 3 |
|
* HTML.pm.src: Since the case t268 should never be reached (no |
| 4 |
|
other token type, there are), it is replaced by a |die| statement. |
| 5 |
|
|
| 6 |
|
2008-03-05 Wakaba <[email protected]> |
| 7 |
|
|
| 8 |
|
* HTML.pm.src: Typo fixed. |
| 9 |
|
|
| 10 |
|
2008-03-04 Wakaba <[email protected]> |
| 11 |
|
|
| 12 |
|
* HTML.pm.src (_tree_construction_initial): Some limited quirks |
| 13 |
|
doctypes were not uppercased for comparison. |
| 14 |
|
|
| 15 |
|
2008-03-03 Wakaba <[email protected]> |
| 16 |
|
|
| 17 |
|
* HTML.pm.src (tree construction and set_inner_html): Checkpoints |
| 18 |
|
are added. |
| 19 |
|
|
| 20 |
|
2008-03-03 Wakaba <[email protected]> |
| 21 |
|
|
| 22 |
|
* HTML.pm.src (_tokenize_attempt_to_consume_an_entity): Checkpoints |
| 23 |
|
are set. Cases that are unlikely reached are noted as so. |
| 24 |
|
|
| 25 |
|
2008-03-03 Wakaba <[email protected]> |
| 26 |
|
|
| 27 |
|
* HTML.pm.src: Checkpoints for debugging are added. |
| 28 |
|
|
| 29 |
|
* mkhtmlparser.pl: Support for |!!!cp| syntax. |
| 30 |
|
|
| 31 |
|
2008-03-03 Wakaba <[email protected]> |
| 32 |
|
|
| 33 |
|
* HTML.pm.src, mkhtmlparser.pl: s/_input_character/_char/g |
| 34 |
|
for simplicity. |
| 35 |
|
|
| 36 |
|
2008-03-03 Wakaba <[email protected]> |
| 37 |
|
|
| 38 |
|
* HTML.pm.src: Flag name changed: s/correct/force-quirks/g (HTML5 |
| 39 |
|
revision 1307). |
| 40 |
|
|
| 41 |
|
2008-03-03 Wakaba <[email protected]> |
| 42 |
|
|
| 43 |
|
* HTML.pm.src (_get_next_token): Where the /incorrect/ flag |
| 44 |
|
is set are changed (HTML5 revision 1305). |
| 45 |
|
|
| 46 |
|
2008-03-02 Wakaba <[email protected]> |
| 47 |
|
|
| 48 |
|
* HTML.pm.src: Raise a parse error for |<span ===>| (HTML5 revision |
| 49 |
|
1292). Entities are not parsed in comment-like part in RCDATA |
| 50 |
|
elements (HTML5 revision 1294). Allow bare & at the end |
| 51 |
|
of attribute value literals (HTML5 revision 1296). More |
| 52 |
|
quirks mode doctypes (HTML5 revision 1302). Requires spaces |
| 53 |
|
between attributes and ban attribute names or unquoted |
| 54 |
|
attribute values containing single or double quotes (HTML5 |
| 55 |
|
revision 1303). |
| 56 |
|
|
| 57 |
|
2008-03-02 Wakaba <[email protected]> |
| 58 |
|
|
| 59 |
|
* ContentChecker.pm: Typo fixed. Don't raise "character encoding" |
| 60 |
|
and related errors unless it is an HTML document (though the spec |
| 61 |
|
is unclear on whether it is applied to XHTML document). |
| 62 |
|
|
| 63 |
|
* HTML.pm (%HTMLAttrStatus): WF2 repetition model attributes |
| 64 |
|
are added. |
| 65 |
|
|
| 66 |
|
2008-03-02 Wakaba <[email protected]> |
| 67 |
|
|
| 68 |
|
* HTML.pm.src: s/local_name/manakai_local_name/g. |
| 69 |
|
|
| 70 |
|
2008-03-01 Wakaba <[email protected]> |
| 71 |
|
|
| 72 |
|
* _NamedEntityList.pm: Updated (HTML5 revision 1286). |
| 73 |
|
|
| 74 |
|
* HTML.pm.src: |charset| in |content| attribute is |
| 75 |
|
case-insensitive (HTML5 revision 1270). |
| 76 |
|
|
| 77 |
|
2008-02-26 Wakaba <[email protected]> |
| 78 |
|
|
| 79 |
|
* ContentChecker.pm: New status constants are added. |
| 80 |
|
($ElementDefault): |status| added. |
| 81 |
|
(check_element): Err for non-standard or deprecated elements. |
| 82 |
|
(_attr_status_info): For non-standard or deprecated attributes. |
| 83 |
|
|
| 84 |
|
2008-02-24 Wakaba <[email protected]> |
| 85 |
|
|
| 86 |
|
* ContentChecker.pm (_attr_status_info): New internal method. |
| 87 |
|
|
| 88 |
|
2008-02-24 Wakaba <[email protected]> |
| 89 |
|
|
| 90 |
|
* ContentChecker.pm (check_element): Element standardized |
| 91 |
|
status information is now dispatched. |
| 92 |
|
|
| 93 |
|
2008-02-24 Wakaba <[email protected]> |
| 94 |
|
|
| 95 |
|
* ContentChecker.pm (check_element): Fix |del|-and-significant |
| 96 |
|
problem by adding some more arguments. |
| 97 |
|
|
| 98 |
|
2008-02-24 Wakaba <[email protected]> |
| 99 |
|
|
| 100 |
|
* ContentChecker.pm (check_element): Use context of |
| 101 |
|
container-for-the-purpose-of-content-model element (not transparent |
| 102 |
|
element) for |check_child_element| calling and significant |
| 103 |
|
text flag marking. This reintroduces |<del>|-and-significant |
| 104 |
|
problem again. |
| 105 |
|
|
| 106 |
|
2008-02-24 Wakaba <[email protected]> |
| 107 |
|
|
| 108 |
|
* ContentChecker.pm (check_element): Make semi-transparent |
| 109 |
|
elements ignored for the purpose of phase changes in |
| 110 |
|
content model checking. |
| 111 |
|
|
| 112 |
|
2008-02-23 Wakaba <[email protected]> |
| 113 |
|
|
| 114 |
|
* ContentChecker.pm (check_element): In-element state |
| 115 |
|
was not properly managed for transparent cases. |
| 116 |
|
|
| 117 |
|
2008-02-23 Wakaba <[email protected]> |
| 118 |
|
|
| 119 |
|
* ContentChecker.pm (check_element): Support for |video| |
| 120 |
|
and |audio| as semi-transparent elements. |
| 121 |
|
|
| 122 |
|
2008-02-23 Wakaba <[email protected]> |
| 123 |
|
|
| 124 |
|
* ContentChecker.pm ($HTMLSemiTransparentElements): New. |
| 125 |
|
(check_element): s/minuses/minus_elements/, s/pluses/plus_elements/. |
| 126 |
|
Support for |html:object| as a semi-transparent element. |
| 127 |
|
|
| 128 |
|
2008-02-23 Wakaba <[email protected]> |
| 129 |
|
|
| 130 |
|
* ContentChecker.pm (check_element): The way to traverse |
| 131 |
|
the tree is entirely revised to make it easier to track |
| 132 |
|
the state of ancestors/descendants. As a result of this |
| 133 |
|
revision (which rewrites almost all of Whatpm::ContentChecker::HTML), |
| 134 |
|
support for content model checking for HTML elements |figure|, |
| 135 |
|
|object|, |video|, and |audio| and checking for XML elements (and |
| 136 |
|
some XMLNS checkings) are dropped for now. They will be |
| 137 |
|
reimplemented in due cource. |
| 138 |
|
|
| 139 |
|
2008-02-17 Wakaba <[email protected]> |
| 140 |
|
|
| 141 |
|
* HTML.pm.src: |>| in public or system literal closes the DOCTYPE |
| 142 |
|
token (HTML5 revision 1225). |
| 143 |
|
|
| 144 |
|
2008-02-17 Wakaba <[email protected]> |
| 145 |
|
|
| 146 |
|
* ContentChecker.pm ({unsupported_level}): New value. |
| 147 |
|
|
| 148 |
|
* HTML.pm.src: Save whether |meta| |content| attribute |
| 149 |
|
contains character references or not. |
| 150 |
|
|
| 151 |
|
2008-02-17 Wakaba <[email protected]> |
| 152 |
|
|
| 153 |
|
* ContentChecker.pm (_get_children): (Incompleted) attempt to |
| 154 |
|
imlement significant content checking for contents |
| 155 |
|
with |del| elements. |
| 156 |
|
|
| 157 |
|
2008-02-17 Wakaba <[email protected]> |
| 158 |
|
|
| 159 |
|
* ContenteChecker.pm ($HTMLTransparentElements): More |
| 160 |
|
elements are added. |
| 161 |
|
(_get_children): HTML |object| elements are now semi-transparent. |
| 162 |
|
|
| 163 |
|
* NanoDOM.pm (manakai_html, manakai_head): New methods. |
| 164 |
|
|
| 165 |
|
2008-02-16 Wakaba <[email protected]> |
| 166 |
|
|
| 167 |
|
* CacheManifest.pm: HTML5 revision 1211 implemented. |
| 168 |
|
|
| 169 |
|
* CacheManifest.pod: Updated. |
| 170 |
|
|
| 171 |
|
2008-02-10 Wakaba <[email protected]> |
| 172 |
|
|
| 173 |
|
* ContentChecker.pm (check_document, check_element): Support |
| 174 |
|
for second argument ($onsubdoc). |
| 175 |
|
(_get_css_parser): Removed (now it is part of WDCC). |
| 176 |
|
|
| 177 |
|
2008-02-09 Wakaba <[email protected]> |
| 178 |
|
|
| 179 |
|
* ContentChecker.pm (_get_css_parser): New. |
| 180 |
|
|
| 181 |
|
2007-11-25 Wakaba <[email protected]> |
| 182 |
|
|
| 183 |
|
* ContentChecker.pm ($AnyChecker): Old way to add child elements |
| 184 |
|
for checking had been used. |
| 185 |
|
|
| 186 |
|
2007-11-25 Wakaba <[email protected]> |
| 187 |
|
|
| 188 |
|
* ContentChecker.pm (check_element): New todo item type |descendant|. |
| 189 |
|
|
| 190 |
|
2007-11-23 Wakaba <[email protected]> |
| 191 |
|
|
| 192 |
|
* IMTChecker.pm: Revised to raise errors and warnings as (poorly) |
| 193 |
|
specced in RFC 2046 and RFC 4288. |
| 194 |
|
(application/atom+xml): Definition added. |
| 195 |
|
|
| 196 |
|
2007-11-23 Wakaba <[email protected]> |
| 197 |
|
|
| 198 |
|
* URIChecker.pm: Make RFC 3986 should-level errors |
| 199 |
|
warnings (rather than SHOULD-level errors). |
| 200 |
|
|
| 201 |
|
2007-11-23 Wakaba <[email protected]> |
| 202 |
|
|
| 203 |
|
* NanoDOM.pm (get_user_data, set_user_data): New methods. |
| 204 |
|
|
| 205 |
|
* HTML.pm.src: A flag for character references in attribute |
| 206 |
|
values are added. Set |manakai_has_reference| user data |
| 207 |
|
to |charset| attribute. |
| 208 |
|
|
| 209 |
2007-11-23 Wakaba <[email protected]> |
2007-11-23 Wakaba <[email protected]> |
| 210 |
|
|
| 211 |
* NanoDOM.pm (input_encoding, manakai_charset, manakai_has_bom): New |
* NanoDOM.pm (input_encoding, manakai_charset, manakai_has_bom): New |